Answer to Question #297440 in Computer Networks for Max

Question #297440

Configure the network as follows:


1) Configure Host Names


2) Shut down unused interfaces.


3) Configure enable password and vty passwords of cisco


4) Use VTP mode transparent and domain ccna


5) Add VLANS 10,20,30,100 to the VLAN database


6) Configure ports between switches as trunks


7) Configure access ports on links to PCs



1
Expert's answer
2022-02-16T04:42:43-0500

Before start you should go to the "Privileged EXEC mode" - do it with "enable" command


Switch>enable

Switch#


(notice the # sign indicates the privileged EXEC mode)


Then go to the "Configuration mode" - do it with "config t" command


Switch>enable

Switch#

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#


1) Configure Host Names - do it with "hostname" command, for example "hostname S1"


Switch>enable

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#

Switch(config)#hostname S1

S1(config)#


2) Shut down unused interfaces. - You should go to the interface level with configuration mode, then use "shutdown" command to shutdown the interface. If you want shutdown the single interface, go to the interface level with "interface" command, for example "interface fa0/1". If you want shutdown the more than one interface, go to the interface level with "interface range" command, for example "interface range gi0/1-2" and "interface range fa0/3-24". After finished, return to the configuration mode via "exit" command.

For example our unused interfaces are both Gbit ports, fast ethernet port #1 and fast ethernet ports #3 - 24.


S1(config)#

S1(config)#interface range gi0/1-2

S1(config-if-range)#shutdown


%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to administratively down


%LINK-5-CHANGED: Interface GigabitEthernet0/2, changed state to administratively down

S1(config-if-range)#exit

S1(config)#interface fa0/1

S1(config-if)#shutdown


%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

S1(config-if)#exit

S1(config)#interface range fa0/3-24

S1(config-if-range)#shutdown


%LINK-5-CHANGED: Interface FastEthernet0/3, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/4, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/5, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/6, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/7, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/8, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/9, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/10, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/11, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/12, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/13, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/14, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/15, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/16, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/17, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/18, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/19, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/20, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/21, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/22, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/23, changed state to administratively down


%LINK-5-CHANGED: Interface FastEthernet0/24, changed state to administratively down

S1(config-if-range)#exit

S1(config)#


3) Configure enable password and vty passwords of cisco - For "enable password" should use "enable password" command, for example, "enable password EXEC#". For "vty password", first should go to the vty line level with configuration mode, use for it "line vty 0 4" command, then via "password" command setup password, for example, "password VTY#". If you want enable login also, before exit, you should apply "login" command.

S1(config)#

S1(config)#enable password EXEC#

S1(config)#

S1(config)#line vty 0 4

S1(config-line)#password VTY#

S1(config-line)#login

S1(config-line)#exit

S1(config)#


4) Use VTP mode transparent and domain ccna - VTP transparent mode setup via "vtp mode transparent" command. VTP domain setup using "vtp domain" command.


S1(config)#

S1(config)#vtp mode transparent

Setting device to VTP TRANSPARENT mode.

S1(config)#vtp domain ccna

Changing VTP domain name from NULL to ccna

S1(config)#


5) Add VLANS 10,20,30,100 to the VLAN database - you should do it via "vlan" command. And before add the next vlan, you should exit from added before vlan level, use "exit" command.


S1(config)#

S1(config)#vlan 10

S1(config-vlan)#exit

S1(config)#vlan 20

S1(config-vlan)#exit

S1(config)#vlan 30

S1(config-vlan)#exit

S1(config)#vlan 100

S1(config-vlan)#exit

S1(config)#


6) Configure ports between switches as trunks - First, go to the interface level ("interface" or "int" command), then use "switchport mode trunk" command. Next, if need add allowed vlan, do it with "switchport trunk allowed vlan" command.

For example, set fast ethernet port #2 as trunk and add allowed vlans 10, 20, 30, 100.


S1(config)#int fa0/2

S1(config-if)#switchport mode trunk

S1(config-if)#switchport trunk allowed vlan 10,20,30,100

S1(config-if)#exit

S1(config)#


7) Configure access ports on links to PCs - First, go to the interface level ("interface" or "int" command), then use "switchport mode access" command. To assign the access port to the necessary vlan you should use "switchport access vlan" command. In the finish use "no shutdown" command to enable this port.

For example, set the fast ethernet port #5 as access port and assign to vlan10.


S1(config)#

S1(config)#int fa0/5

S1(config-if)#switchport mode access

S1(config-if)#switchport access vlan 10

S1(config-if)#no shutdown


%LINK-5-CHANGED: Interface FastEthernet0/5, changed state to down

S1(config-if)#end

S1#

%SYS-5-CONFIG_I: Configured from console by console


S1#


(notice - "Exit" command takes you back one mode. For example, say you are in Interface Configuration mode, exit will take you back to Global Configuration mode.

"End" command takes you back to priviliged/enable mode from any deeper mode. If you typed end in, for example, interface configuration mode, it would drop you back to Priviliged mode.)


After finished you should save the running configuration to the startup configuration file.


S1#

S1#write memory

Building configuration...

[OK]

S1#copy running-config startup-config

Destination filename [startup-config]?

Building configuration...

[OK]

S1#






Need a fast expert's response?

Submit order

and get a quick answer at the best price

for any assignment or question with DETAILED EXPLANATIONS!

Comments

No comments. Be the first!

Leave a comment

LATEST TUTORIALS
New on Blog
APPROVED BY CLIENTS